const regex = /([\p{L}\p{Nd}]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\p{L}\\p{Nd}]+)', 'g')
const str = `jshdgudgdi^dlnhddhjdhdhdhdkjdh
&%\$#@#\$%^&*()
dndjjskjdlkdjnskjdkjd
nshhd
%#\$%01763543892
English:
Finally done, this was the 6th or sixth test.
Russian:
Наконец сделано , это было 6-й или шестой тест .
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}