import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\p{L}\\p{Nd}]+)";
final String string = "jshdgudgdi^dlnhddhjdhdhdhdkjdh\n"
+ "&%$#@#$%^&*()\n"
+ "dndjjskjdlkdjnskjdkjd\n\n"
+ "nshhd\n\n"
+ "%#$%01763543892\n\n"
+ "English:\n\n"
+ "Finally done, this was the 6th or sixth test.\n\n"
+ "Russian:\n\n"
+ "Наконец сделано , это было 6-й или шестой тест .\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}