import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\'(UTF\\-8)\\'";
final String string = "<img src'UTF-8' width='100' scalefit='1'>\n"
+ "<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>\n"
+ "<form action='http://www.website.com/action.php?action=$action_type' method='post'>";
final String subst = "\"\\1\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}