use strict;
my $str = '<img src\'UTF-8\' width=\'100\' scalefit=\'1\'>
<a href=\'http://www.website.com/page.php?variable1=a&variable2=b\'>Click Here</a>
<form action=\'http://www.website.com/action.php?action=$action_type\' method=\'post\'>';
my $regex = qr/\'(UTF\-8)\'/p;
my $subst = '"\\1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";