const regex = /\'(UTF\-8)\'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\'(UTF\\-8)\\\'', 'g')
const str = `<img src'UTF-8' width='100' scalefit='1'>
<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>
<form action='http://www.website.com/action.php?action=\$action_type' method='post'>`;
const subst = `"\1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);