re = /\'(UTF\-8)\'/
str = '<img src\'UTF-8\' width=\'100\' scalefit=\'1\'>
<a href=\'http://www.website.com/page.php?variable1=a&variable2=b\'>Click Here</a>
<form action=\'http://www.website.com/action.php?action=$action_type\' method=\'post\'>'
subst = '"\\1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result