# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\'(UTF\-8)\'"
test_str = ("<img src'UTF-8' width='100' scalefit='1'>\n"
"<a href='http://www.website.com/page.php?variable1=a&variable2=b'>Click Here</a>\n"
"<form action='http://www.website.com/action.php?action=$action_type' method='post'>")
subst = "\"\\1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.