#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\/(\w+)(?:\..*)(\w{2,3})\#)"
Local $sString = "//source/project/file.cs#232" & @CRLF & _
"path "//source/project/file.initial.config.cs#232""
Local $sSubst = "$2.$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)