import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/(\\w+)(?:\\..*)(\\w{2,3})\\#)";
final String string = "//source/project/file.cs#232\n"
+ "path \"//source/project/file.initial.config.cs#232\"";
final String subst = "$2.$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}