// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/(\w+)(?:\..*)(\w{2,3})\#)").unwrap();
let string = "//source/project/file.cs#232
path \"//source/project/file.initial.config.cs#232\"";
let substitution = "$2.$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}