# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/(\w+)(?:\..*)(\w{2,3})\#)"
test_str = ("//source/project/file.cs#232\n"
"path \"//source/project/file.initial.config.cs#232\"")
subst = "$2.$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.