package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/(\w+)(?:\..*)(\w{2,3})\#)`)
var str = `//source/project/file.cs#232
path "//source/project/file.initial.config.cs#232"`
var substitution = "$2.$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}