const regex = new RegExp('(\\/(\\w+)(?:\\..*)(\\w{2,3})\\#)', 'g')
const str = `//source/project/file.cs#232
path "//source/project/file.initial.config.cs#232"`;
const subst = `$2.$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);