use strict;
my $str = '//source/project/file.cs#232
path "//source/project/file.initial.config.cs#232"';
my $regex = qr/(\/(\w+)(?:\..*)(\w{2,3})\#)/p;
my $subst = '$2.$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";