using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/(\w+)(?:\..*)(\w{2,3})\#)";
string substitution = @"$2.$3";
string input = @"//source/project/file.cs#232
path ""//source/project/file.initial.config.cs#232""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}