# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\s"'\\]+)*("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)/$1$2 /g;t' <<< "a b c d e
a b \"c d\" e
a b 'c d' e
a b \"c d' e"