using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s""'\\]+)*(""[^""\\]*(?:\\.[^""\\]*)*""|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)";
string substitution = @"$1$2 ";
string input = @"a b c d e
a b ""c d"" e
a b 'c d' e
a b ""c d' e";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}