package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\s"'\\]+)*("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)`)
var str = `a b c d e
a b "c d" e
a b 'c d' e
a b "c d' e`
var substitution = "$1$2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}