#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\s"'\\]+)*("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)"
Local $sString = "a b c d e" & @CRLF & _
"a b "c d" e" & @CRLF & _
"a b 'c d' e" & @CRLF & _
"a b "c d' e"
Local $sSubst = "$1$2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)