$re = '/([^\s"\'\\\\]+)*("[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|\'[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')*(\s+)/';
$str = 'a b c d e
a b "c d" e
a b \'c d\' e
a b "c d\' e';
$subst = "$1$2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;