import re
regex = re.compile(r"([^\s\"'\\]+)*(\"[^\"\\]*(?:\\.[^\"\\]*)*\"|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)")
test_str = ("a b c d e\n"
"a b \"c d\" e\n"
"a b 'c d' e\n"
"a b \"c d' e")
subst = "$1$2 "
result = regex.sub(subst, test_str)
if result:
print(result)