#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}"
Local $sString = "{n}{n}A{n}{n}A{n}" & @CRLF & _
"{n}A{n}{n}{n}{n}A" & @CRLF & _
"{n}{n}A{n}A{n}{n}" & @CRLF & _
"{n}{n}{n}A{n}A{n}B" & @CRLF & _
"{n}A{n}{n}B{n}{n}" & @CRLF & _
"A{n}B{n}{n}{n}{n}"
Local $sSubst = "C"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)