import Foundation
let pattern = #"(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{n}{n}A{n}{n}A{n}
{n}A{n}{n}{n}{n}A
{n}{n}A{n}A{n}{n}
{n}{n}{n}A{n}A{n}B
{n}A{n}{n}B{n}{n}
A{n}B{n}{n}{n}{n}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"C"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)