const regex = /(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=A){n}(?=(?:{n})*A)|\\G(?!^){n}', 'g')
const str = `{n}{n}A{n}{n}A{n}
{n}A{n}{n}{n}{n}A
{n}{n}A{n}A{n}{n}
{n}{n}{n}A{n}A{n}B
{n}A{n}{n}B{n}{n}
A{n}B{n}{n}{n}{n}`;
const subst = `C`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);