use strict;
my $str = '{n}{n}A{n}{n}A{n}
{n}A{n}{n}{n}{n}A
{n}{n}A{n}A{n}{n}
{n}{n}{n}A{n}A{n}B
{n}A{n}{n}B{n}{n}
A{n}B{n}{n}{n}{n}';
my $regex = qr/(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}/p;
my $subst = 'C';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";