re = /(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}/
str = '{n}{n}A{n}{n}A{n}
{n}A{n}{n}{n}{n}A
{n}{n}A{n}A{n}{n}
{n}{n}{n}A{n}A{n}B
{n}A{n}{n}B{n}{n}
A{n}B{n}{n}{n}{n}'
subst = 'C'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result