using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}";
string substitution = @"C";
string input = @"{n}{n}A{n}{n}A{n}
{n}A{n}{n}{n}{n}A
{n}{n}A{n}A{n}{n}
{n}{n}{n}A{n}A{n}B
{n}A{n}{n}B{n}{n}
A{n}B{n}{n}{n}{n}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}