import re
regex = re.compile(r"(?<=A){n}(?=(?:{n})*A)|\G(?!^){n}")
test_str = ("{n}{n}A{n}{n}A{n}\n"
"{n}A{n}{n}{n}{n}A\n"
"{n}{n}A{n}A{n}{n}\n"
"{n}{n}{n}A{n}A{n}B\n"
"{n}A{n}{n}B{n}{n}\n"
"A{n}B{n}{n}{n}{n}")
subst = "C"
result = regex.sub(subst, test_str)
if result:
print(result)