#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\]\s*(?:\d+|[a-zA-Z]+)\.\s*"
Local $sString = "[ 1.1 ] 1. A method of providing a master" & @CRLF & _
"[ 12.1 ] 12. An apparatus for providing" & @CRLF & _
"[ 39.3 ] b. one or more control point applications" & @CRLF & _
"[ 39.8 ] iv. a server application programming interface" & @CRLF & _
"[ 30.2 ] a. a client application programming" & @CRLF & _
"[ 1.2 ] an RFID device provided"
Local $sSubst = "] "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)