import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\]\\s*(?:\\d+|[a-zA-Z]+)\\.\\s*";
final String string = "[ 1.1 ] 1. A method of providing a master\n"
+ "[ 12.1 ] 12. An apparatus for providing\n"
+ "[ 39.3 ] b. one or more control point applications\n"
+ "[ 39.8 ] iv. a server application programming interface\n"
+ "[ 30.2 ] a. a client application programming\n"
+ "[ 1.2 ] an RFID device provided";
final String subst = "] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}