// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\]\s*(?:\d+|[a-zA-Z]+)\.\s*").unwrap();
let string = "[ 1.1 ] 1. A method of providing a master
[ 12.1 ] 12. An apparatus for providing
[ 39.3 ] b. one or more control point applications
[ 39.8 ] iv. a server application programming interface
[ 30.2 ] a. a client application programming
[ 1.2 ] an RFID device provided";
let substitution = "] ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}