package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\]\s*(?:\d+|[a-zA-Z]+)\.\s*`)
var str = `[ 1.1 ] 1. A method of providing a master
[ 12.1 ] 12. An apparatus for providing
[ 39.3 ] b. one or more control point applications
[ 39.8 ] iv. a server application programming interface
[ 30.2 ] a. a client application programming
[ 1.2 ] an RFID device provided`
var substitution = "] "
fmt.Println(re.ReplaceAllString(str, substitution))
}