# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/(?![^{]*\})/\n/g;t' <<< "/foo/bar/{epoch:06d}-{valid/total_loss:.3f}"