#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/(?![^{]*\})"
Local $sString = "/foo/bar/{epoch:06d}-{valid/total_loss:.3f}"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)