import Foundation
let pattern = #"\/(?![^{]*\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/foo/bar/{epoch:06d}-{valid/total_loss:.3f}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)