use strict;
my $str = '/foo/bar/{epoch:06d}-{valid/total_loss:.3f}';
my $regex = qr/\/(?![^{]*\})/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";