re = /\/(?![^{]*\})/
str = '/foo/bar/{epoch:06d}-{valid/total_loss:.3f}'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result