import re
regex = re.compile(r"\/(?![^{]*\})")
test_str = "/foo/bar/{epoch:06d}-{valid/total_loss:.3f}"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)