using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(?![^{]*\})";
string substitution = @"\n";
string input = @"/foo/bar/{epoch:06d}-{valid/total_loss:.3f}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}