$re = '/\/(?![^{]*\})/';
$str = '/foo/bar/{epoch:06d}-{valid/total_loss:.3f}';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;