#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).*(services\/city|specials\/limited|services|specials)\/[^\/\n]*"
Local $sString = "www.fake.com/services/home" & @CRLF & _
" -> (legal, no trim) -> www.fake.com/services/home" & @CRLF & _
"" & @CRLF & _
"www.fake.com/services/city/nyc" & @CRLF & _
" -> (legal, no trim) -> www.fake.com/services/city/nyc" & @CRLF & _
"" & @CRLF & _
"www.fake.com/services/city/nyc/fakeinjection.txt" & @CRLF & _
" -> (illegal) -> www.fake.com/services/city/nyc" & @CRLF & _
"" & @CRLF & _
"www.fake.com/specials/limited/california/fake/fake/fake.bak" & @CRLF & _
" -> (illegal) -> www.fake.com/specials/limited/california"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")