use strict;
my $str = 'www.fake.com/services/home
-> (legal, no trim) -> www.fake.com/services/home
www.fake.com/services/city/nyc
-> (legal, no trim) -> www.fake.com/services/city/nyc
www.fake.com/services/city/nyc/fakeinjection.txt
-> (illegal) -> www.fake.com/services/city/nyc
www.fake.com/specials/limited/california/fake/fake/fake.bak
-> (illegal) -> www.fake.com/specials/limited/california';
my $regex = qr/.*(services\/city|specials\/limited|services|specials)\/[^\/\n]*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}