$re = '/.*(services\/city|specials\/limited|services|specials)\/[^\/\n]*/i';
$str = 'www.fake.com/services/home
-> (legal, no trim) -> www.fake.com/services/home
www.fake.com/services/city/nyc
-> (legal, no trim) -> www.fake.com/services/city/nyc
www.fake.com/services/city/nyc/fakeinjection.txt
-> (illegal) -> www.fake.com/services/city/nyc
www.fake.com/specials/limited/california/fake/fake/fake.bak
-> (illegal) -> www.fake.com/specials/limited/california';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);