import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(services\\/city|specials\\/limited|services|specials)\\/[^\\/\\n]*";
final String string = "www.fake.com/services/home\n"
+ " -> (legal, no trim) -> www.fake.com/services/home\n\n"
+ "www.fake.com/services/city/nyc\n"
+ " -> (legal, no trim) -> www.fake.com/services/city/nyc\n\n"
+ "www.fake.com/services/city/nyc/fakeinjection.txt\n"
+ " -> (illegal) -> www.fake.com/services/city/nyc\n\n"
+ "www.fake.com/specials/limited/california/fake/fake/fake.bak\n"
+ " -> (illegal) -> www.fake.com/specials/limited/california";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}