package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).*(services\/city|specials\/limited|services|specials)\/[^\/\n]*`)
var str = `www.fake.com/services/home
-> (legal, no trim) -> www.fake.com/services/home
www.fake.com/services/city/nyc
-> (legal, no trim) -> www.fake.com/services/city/nyc
www.fake.com/services/city/nyc/fakeinjection.txt
-> (illegal) -> www.fake.com/services/city/nyc
www.fake.com/specials/limited/california/fake/fake/fake.bak
-> (illegal) -> www.fake.com/specials/limited/california`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}