using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(services\/city|specials\/limited|services|specials)\/[^\/\n]*";
string input = @"www.fake.com/services/home
-> (legal, no trim) -> www.fake.com/services/home
www.fake.com/services/city/nyc
-> (legal, no trim) -> www.fake.com/services/city/nyc
www.fake.com/services/city/nyc/fakeinjection.txt
-> (illegal) -> www.fake.com/services/city/nyc
www.fake.com/specials/limited/california/fake/fake/fake.bak
-> (illegal) -> www.fake.com/specials/limited/california";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}