import Foundation
let pattern = #".*(services\/city|specials\/limited|services|specials)\/[^\/\n]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
www.fake.com/services/home
-> (legal, no trim) -> www.fake.com/services/home
www.fake.com/services/city/nyc
-> (legal, no trim) -> www.fake.com/services/city/nyc
www.fake.com/services/city/nyc/fakeinjection.txt
-> (illegal) -> www.fake.com/services/city/nyc
www.fake.com/specials/limited/california/fake/fake/fake.bak
-> (illegal) -> www.fake.com/specials/limited/california
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)