# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(services\/city|specials\/limited|services|specials)\/[^\/\n]*"
test_str = ("www.fake.com/services/home\n"
" -> (legal, no trim) -> www.fake.com/services/home\n\n"
"www.fake.com/services/city/nyc\n"
" -> (legal, no trim) -> www.fake.com/services/city/nyc\n\n"
"www.fake.com/services/city/nyc/fakeinjection.txt\n"
" -> (illegal) -> www.fake.com/services/city/nyc\n\n"
"www.fake.com/specials/limited/california/fake/fake/fake.bak\n"
" -> (illegal) -> www.fake.com/specials/limited/california")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.