# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}/1-9/g;t' <<< "1,2;2,3;4,5;0,3"