use strict;
my $str = '1,2;2,3;4,5;0,3';
my $regex = qr/(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}/p;
my $subst = '1-9';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";